Problems with the ClientCmd
  1. #1

    Problems with the ClientCmd

    Hi,
    I have a problem with the ClientCmd command.
    Example:

    working:
    Code:
    base.m_pEngine->ClientCmd("mat_fullbright 1");
    not working (why?):
    Code:
    base.m_pEngine->ClientCmd("exec fdm.cfg");
    thX, thoseHacker!

  2. #2
    test it without ".cfg". i think it is not needed ...


    Helo

  3. #3
    Oh, I forgot the error message.
    Code:
    Unknown command "exec"
    not working too:
    Code:
    base.m_pEngine->ClientCmd("name d-fsdkfhsjvdfnvk");
    Same error with "name".

    thx, thoseHacker!

  4. #4
    Code:
    ConCommandBase* fb = main.m_pCvar->FindVar("mat_fullbright");
    fb->SetValue(1.0f);
    should work.
    How To Contact Me@[b/]

    Private Message me for any important issues or just say Hi :) I'm not a robot.

    ---- (No Support!) ----
    Wanna Hang out ? Add me or Join my communities below:

    Add be on Discord : dr0ps25#7946 ;-)
    or Join Our Community Server :
    dr0ps Project-7 Telegram Community Chat: https://t.me/+pAb_mrtrjXg1ZDlk

    ---- (24/7 Customer Support) ----

    Private Message
    Email: " support 'at' Project-7. 'net' "

    Create Support Ticket on Discord!
    Discord Server:



    Would you like to work in the cheating industry ? Project-7 is hiring a varient of new employees. We're currently in requisite of quite a few talents to add into the relaunched company now that we have a more professional and precise structure in place to provide real paid work for anyone willing to help our team grow:[/b]

    We're currently looking for multiple types of forum moderators and content creators/posters, we're offering quite a few paid positions for you to just talk about cheats on the community!






  5. #5
    Do it work when I use the following?

    Code:
    ConCommandBase* fb = main.m_pCvar->FindVar("name");
    fb->SetValue("thisismyfuckinnewname?");
    Thx fumin!

    If I try it with exec or name, both give the same error - unknown Command.

  6. #6
    Hey, I don't want to spam, but nothing of this works.
    I need a command to exec a cfg:
    Code:
    m_pEngine->ClientCmd("exec bla.cfg");
    doesn't work!
    This error appears:
    Code:
    FCVAR_CLIENTCMD_CAN_EXECUTE prevented running command: exec
    Unknown command: exec
    Thx, thoseHacker

  7. #7

  8. #8
    i guess fcvar whatever is some cvar flag
    Code:
       ConCommandBase* Cvar = HellosCheat.pCvar->FindVar("exec" );
    
    
        if(Cvar)
        {
            if(!Cvar->IsBitSet(FCVAR_CLIENTCMD_CAN_EXECUTE))
                Cvar->m_nFlags |= FCVAR_CLIENTCMD_CAN_EXECUTE;
        }

  9. #9
    Thx, Hello!
    But the compiler doesn't know what FCVAR_CLIENTCMD_CAN_EXECUTE is...
    I looked into the Developer Console Control - Valve Developer Community , but theres nothing which can be pass my problem...

    FCVAR_CLIENTCMD_CAN_EXECUTE prevented running command: exec
    Unknown command: exec

    thoseHacker

  10. #10
    i know that this hack is 1 year old

    but use
    Code:
    m_pEngine->ExecuteClientCmd("exec blah");
    i just dont like it if there is no solution in threads

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in